• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

deepin20 安装英伟达闭源驱动

开发技术 开发技术 2周前 (09-08) 19次浏览

第一步、安装深度的“显卡驱动器”

deepin v20 中默认没有显卡驱动管理器,需要命令行安装,命令如下(刚开始一直出错,当我第一次打开应用商店,就可以安装了,好神奇):

sudo apt install deepin-graphics-driver-manager

安装深度的“显卡驱动器”,切换到因特尔默认驱动,然后重启两次,确认切换成功后,进行下一步。

第二步、卸载英伟达开源驱动

如果刚刚安装好系统,什么都没操作,那么这一步可以省略。

sudo apt autoremove nvidia-*

第三步、禁止nouveau驱动

这一步也是最最关键的,就是禁止nouveau驱动,话不多说,上代码(记得打开终端的时候切换到root权限)。

  sudo dedit /etc/modprobe.d/blacklist.conf

在打开的 blacklist.conf 文件中复制以下内容并保存关闭:

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

保存并关闭文本后,继续在终端中输入代码:

sudo update-initramfs -u

好了,截止到目前,双显卡安装英伟达显卡的前期准备工作已经全部完成了!

第四步、安装英伟达闭源驱动

第一步:打开终端,在“root”权限下,使用命令:

sudo apt install nvidia-driver

然后就开始在终端安装最新的英伟达显卡驱动了,其中有需要确认安装的,输入“y”再回车就好了。

在第一步安装执行完成后,进行第二步前,使用命令:

lspci | egrep "VGA|3D"

查看在显示的最前面的数字中,我的英伟达显卡前面显示的是“01:00:00”所以后面的“X:X:X”替换成“1:0:0”(根据自己电脑输出的是什么数字,对比更改就行了)

第二步:使用命令:

sudo dedit /etc/X11/xorg.conf

在打开的文本中复制一下内容(这里要进行转换一下:01:00:00 –> 1:0:0,即PCI:1:0:0):

 Section "Module"
   Load "modesetting"
 EndSection
 Section "Device"
   Identifier "nvidia"
   Driver "nvidia"
   BusID "PCI:X:X:X"    
   Option "AllowEmptyInitialConfiguration"
 EndSection

第三步:使用命令:

sudo dedit ~/.xinitrc

同理,在打开的文本中复制以下内容,然后保存关闭文本。

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
xrandr --dpi 96

第四步:使用命令:

sudo dedit /etc/lightdm/display_setup.sh

同理,在打开的文本中复制以下内容,然后保存关闭文本。

#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
xrandr --dpi 96

第五步:使用命令赋予“第四步”的文本运行权限:

sudo chmod +x /etc/lightdm/display_setup.sh

第六步:使用命令:

sudo dedit /etc/lightdm/lightdm.conf

在打开的文本中,找到[Seat:*]这一行,然后在[Seat:*]行下添加如下代码:

display-setup-script=/etc/lightdm/display_setup.sh

第五步、nvidia-smi 验证

截止到这里,所有的安装工作就结束了。然后重启系统就。在终端输入 nvidia-smi 后,如果打印出显卡驱动信息,那么说明安装成功。

如果在终端输入 nvidia-smi 无反应,那么需要执行如下命令:

sudo apt update -y && sudo apt install nvidia-smi -y

可能会报没找到依赖的错误,那么根据提示安装需要的依赖就行。

sudo apt install plymouth-themes console-setup

在执行安装 nvidia-smi 命令,就可以成功安装了。

参考

以上内容都是基于 https://bbs.deepin.org/forum.php?mod=viewthread&tid=192957 上从新排版和整理,为以后安装做备份。


喜欢 (0)