• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

org.apache.jasper.JasperException: Unable to compile class for JSP

开发技术 开发技术 3周前 (09-11) 35次浏览

今天在使用tomcat跑项目的时候遇到了如下错误

org.apache.jasper.JasperException: Unable to compile class for JSP

引起错误的原因:

由报错信息分析浏览器中的错误页面可以看到此时运行的tomcat版本是6.0.29,而我们项目中用到的jdk是1.8,所以猜测这应该是tomcat与jdk版本不兼容引起的

解决方案:

只要我们换用版本更高的tomcat即可

maven

使用maven的就很简单了,直接在pom.xml中配置一下即可
org.apache.jasper.JasperException: Unable to compile class for JSP
代码如下

<plugin>
            <groupId>org.apache.tomcat.maven</groupId>
            <artifactId>tomcat7-maven-plugin</artifactId>
            <version>2.2</version>
            <configuration>
                <port>8888</port>
            </configuration>
        </plugin>

再进行以上操作之后我就成功的运行了web项目。对此有疑问的同学可以私信我,我可以帮助进行解决, 撰文不易,如有帮助请点赞关注支持支持作者

org.apache.jasper.JasperException: Unable to compile class for JSP


喜欢 (0)