• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

UNI-APP_uni打包后提示,本应用使用HBuilderX 2.8.12 或对应的cli版本编译,而手机端SDK版本是2.8.13,不匹配的版本可能造成应用异常。解决

互联网 diligentman 2周前 (10-17) 9次浏览

HBuilderX1.7.0及以上版本uni-app添加了运行环境版本和编译环境版本的校验机制,当两个版本不一致时会弹出以下提示:
UNI-APP_uni打包后提示,本应用使用HBuilderX 2.8.12 或对应的cli版本编译,而手机端SDK版本是2.8.13,不匹配的版本可能造成应用异常。解决
解决办法:
可以在manifest.json文件的源码视图中配置忽略这个提醒,方式如下:

HBuilderX1.9.0及以上版本新增以下配置避免弹出提示框

//...  
"app-plus": {
   
     
	"compatible": {
   
     
	    "ignoreVersion": true //true表示忽略版本检查提示框,HBuilderX1.9.0及以上版本支持  
	},  
	//....  
},  
//...

以下方法可针对指定版本避免弹出提示框

//...  
"app-plus": {
   
     
	"compatible": {
   
     
	    "runtimeVersion": "1.7.0", //根据实际情况填写  
	    "compilerVersion": "1.7.1" //根据实际情况填写  
	},  
	//....  
},  
//...

喜欢 (0)