• 微信公众号:美女很有趣。 工作之余,放松一下,关注即送10G+美女照片!

vue安装less报错

开发技术 开发技术 2周前 (04-30) 11次浏览

执行npm install less less-loader –save-dev命令,报错如下:

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: xxx@1.0.0
npm ERR! Found: webpack@3.12.0       
npm ERR! node_modules/webpack        
npm ERR!   dev webpack@"^3.6.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer webpack@"^5.0.0" from less-loader@8.0.0
npm ERR! node_modules/less-loader
npm ERR!   less-loader@"*" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See C:UsersxxxxxxAppDataLocalnpm-cacheeresolve-report.txt for a full report.
npm ERR!
npm ERR! A complete log of this run can be found in:
npm ERR!     C:UsersxxxxxxAppDataLocalnpm-cache_logs2021-03-01T12_00_00_216Z-debug.log

 

原因

less本版太高需要降低版本

 

方法
先移除之前版本:npm uninstall less-loader
下载指定版本:npm install less-loader@5.0.0 -D

* 若还是报错可移除文件node_modules,重新下载cnpm install

 


程序员灯塔
转载请注明原文链接:vue安装less报错
喜欢 (0)