• 微信公众号:美女很有趣。 工作之余,放松一下,关注即送10G+美女照片!

NAT

开发技术 开发技术 2周前 (05-03) 8次浏览

NAT

1. Network Address Translations
  网络地址转换
2. ipv4地址严重不够用
  A B C类可以使用 D组播 E科研
3. IP地址分为公网IP和私网IP
  公网IP只能在公网上使用
  私网IP只能在内网中使用
PS: 公网上不允许出现私有IP地址!!!
  私网IP可以重复在内网使用
  192.168.1.1
  私有IP地址范围
    1) 10.0.0.0/8 (10开头的)
    2) 172.16.0.0/16 -172.31.0.0/16 (172.16开头的一直到172.31开头的)
    3) 192.168.0.0/16 (192.168开头的)
4. NAT主要实现公私有IP地址的转换,一般是路由器或者防火墙上来完成,不建议在三层交换机上配置
5. NAT有3大类:
  1)静态NAT
  1对1映射,(静态PAT,端口映射映射)
  2)动态NAT
  3)PAT(端口地址转换,Port Address Translations)
  PAT端口复用技术
NAT

6. NAT命令
1) 定义内网端口
interface f0/0
    ip nat inside
2) 定义外网端口
interface f0/1
    ip nat outside    
3) 配置PAT
定义内部地址池
access-list 1 permit 192.168.0.0 0.0.255.255
做PAT动态映射
config terminal
    ip nat inside source list 1 interface f0/1 overload
4) 配置静态端口转换
config terminal
    ip nat inside source static tcp 192.168.1.3 80 100.1.1.2 80
5) 查看nat表信息
show ip nat translations
NAT实验

 NAT

实验需求:

1)要求使用nat技术实现图中私网中的网络设备,可以访问互联网上的xx设备
2)要求使用nat技术实现互联网中的xx设备可以访问私网的200和201服务器上的80服务
core路由器配置
core(config)#interface f0/0
core(config-if)#ip address 192.168.1.254 255.255.255.0
core(config-if)#ip nat inside        //定义内网端口
core(config-if)#no shutdown
core(config-if)#exit
core(config)#interface f0/1
core(config-if)#ip address 100.1.1.1 255.255.255.0
core(config-if)#ip nat outside        //定义外网端口
core(config-if)#no shutdown 
core(config-if)#exit
//配置路由
core(config)#ip route 0.0.0.0 0.0.0.0 100.1.1.2
//配置NAT
core(config)#access-list 1 permit 192.168.1.0 0.255.255.255
core(config)#ip nat inside source list 1 interface f0/1 overload
core(config)#ip nat inside source static tcp 192.168.1.201 80 100.1.1.3 80
core(config)#ip nat inside source static tcp 192.168.1.200 80 100.1.1.4 80
out-r1路由器的配置
Router(config)#hostname out-r1
out-r1(config)#interface f0/0
out-r1(config-if)#ip address 100.1.1.2 255.255.255.0
out-r1(config-if)#no shutdown 
out-r1(config-if)#exit
out-r1(config)#interface f0/1
out-r1(config-if)#ip address 150.1.1.1 255.255.255.0
out-r1(config-if)#no shutdown 
out-r1(config-if)#exit
//配置路由
out-r1(config)#ip route 200.1.1.0 255.255.255.0 150.1.1.2
out-r2路由器的配置
Router(config)#hostname out-r2
out-r2(config)#interface f0/0
out-r2(config-if)#ip address 150.1.1.2 255.255.255.0
out-r2(config-if)#no shutdown
out-r2(config-if)#exit
out-r2(config)#interface f0/1
out-r2(config-if)#ip address 200.1.1.254 255.255.255.0
out-r2(config-if)#no shutdown 
out-r2(config-if)#exit
//配置路由
out-r2(config)#ip route 0.0.0.0 0.0.0.0 150.1.1.1
验证

 NAT

动态路由

 NAT

1. 基于某种路由协议实现
2. 动态路由协议概述
  路由器之间用来交换信息的语言
3. 动态路由
  基于某种路由协议实现
4. 动态路由特点
  减少了管理任务
  占用了网络带宽
5. 度量值
  跳数、带宽、负载、时延、可靠性、成本

 NAT

6. 收敛
  使所有路由表都达到一致状态的过程
7. 静态路由与动态路由的比较
  网络中静态路由和动态路由互相补充
8. 按照路由执行的算法分类
  距离矢量路由协议
    依据从源网络到目标网络所经过的路由器的个数选择路由
    RIP、IGRP
  链路状态路由协议
    综合考虑从源网络到目标网络的各条路径的情况选择路由
    OSPF、IS-IS
9. RIP是距离-矢量路由选择协议
10. RIP的基本概念
  定期更新
  邻居
  广播更新
  全路由表更新
路由器学习到直连路由
更新周期30s到时,路由器会向邻居发送路由表

 NAT

再过30s,第二个更新周期到了再次发送路由表

 NAT

RIP度量值为条数
  最大条数为15跳,16跳为不可达
RIP更新时间
  每隔30s发送路由更新时间,UDP520端口
RIP路由更新消息
  发送整个路由表信息
11. 路由环路

 NAT

 

 NAT

NAT

执行水平分割可以阻止路由环路的发生
  从一个接口学习到路由信息,不再从这个接口发送出去
  同时也能减少路由更新信息占用的链路带宽资源

相关命令

RIP v1:
config terminal
router rip            //启用RIP进程
    version 1        //版本1
    network 10.0.0.0     //宣告主网络号
RIP v2:
config terminal
router rip            //启用RIP进程
    version 2        //版本2
    network 10.0.0.0     //宣告主网络号   
    no auto-summary    //关闭自动汇总
//查看动态路由协议
show ip protocols

 

 


程序员灯塔
转载请注明原文链接:NAT
喜欢 (0)