• 微信公众号:美女很有趣。 工作之余,放松一下,关注即送10G+美女照片!

ko与内核版本不一致,出现"invalid module format"的问题

开发技术 开发技术 9小时前 5次浏览

  在使用insmod xxx.ko这条命令时出现如下错误信息,网络上有很多关于此问题的方法,但是好久不得要领,这里特意记录我可以OK的步骤,当然也都是别人提到过的方法

ko与内核版本不一致,出现"invalid module format"的问题

 

1.在内核中去掉模块版本检查,路径:Enable loadable module support  —>[]   Module versioning support

ko与内核版本不一致,出现"invalid module format"的问题

 

2. 将ko的Makefile编译指令的目录指定到目标板的内核源码所在位置(需要内核已经编译过)

ko与内核版本不一致,出现"invalid module format"的问题

ko与内核版本不一致,出现"invalid module format"的问题

 

  按照以上即可OK,最开始我的Makefile如下,是直接照搬过来的,没有仔细研究过,所以只能在PC上运行,而无法在目标板上加载

ko与内核版本不一致,出现"invalid module format"的问题

 


程序员灯塔
转载请注明原文链接:ko与内核版本不一致,出现"invalid module format"的问题
喜欢 (0)