• 微信公众号:美女很有趣。 工作之余,放松一下,关注即送10G+美女照片!

golang引用第三方包的报错:no required module provides package [完美解决]

开发技术 开发技术 4小时前 3次浏览

关于golang第三方包的引用报错:no required module provides package : go.mod file not found in current directory or any parent directory;

需要倒入包:
go get github.com/denisenkom/go-mssqldb
go get github.com/mattn/go-adodb
全部无反应,着手去分析问题到底出在哪里?

命令:go  env

先排除 go env 里面:GO111MODULE  (我的是GO111MODULE=”on”,导致下载失败)

 

执行:go env -w GO111MODULE=auto


喜欢 (0)