• 欢迎光临~

详解Python当中的pip常用命令

开发技术 开发技术 2022-07-26 次浏览
原文链接:https://mp.weixin.qq.com/s/GyUKj_7mOL_5bxUAJ5psBw

 

小编相信对于大多数熟悉Python的人来说,一定都听说并且使用过pip这个工具,但是对它的了解可能还不一定是非常的透彻,今天小编就来为大家介绍10个使用pip的小技巧,相信对大家以后管理和使用Python当中的标准库会有帮助。

安装

当然在Python 3.4版本之后以及Python 2.7.9版本之后,官网的安装包当中就已经自带了pip,用户直接在安装完Python之后就可以直接使用,要是使用由virtualenv或者pyvenv创建的虚拟环境,那么pip也是被默认安装的

如果是需要自己另外安装pip包的,在已经配置好Python的环境当中运行下面这个命令行

py -m ensurepip --upgrade

另外一种方式是从官网上(https://bootstrap.pypa.io/get-pip.py)直接下载get-pip.py脚本,然后直接运行python get-pip.py脚本即可

如何使用

安装后,在命令行中输入pip,然后按下回车,就会出现使用说明:

升级

要是你觉得自己的pip版本有点低,想要升级一下的话,在命令行中输入以下命令

pip install --upgrade pip

或者是

pip install -U pip

安装某个版本的包

如果打算用pip来安装第三方的包,用的是以下的命令行

pip install package-name

例如我们想要安装指定版本的第三方的包,例如安装3.4.1版本的matplotlib,

pip install matplotlib==3.4.1

卸载或者是更新包

要是你打算想要卸载某个包,该要输入的命令行是

pip uninstall package_name

而如果打算更新某个包,对应的命令行是

pip install --upgrade package_name
# 或者是
pip install -U package_name

查看某个包的信息

可以通过以下的这个命令行来查看指定包的信息,

pip show -f requests

output

Name: requests
Version: 2.24.0
Summary: Python HTTP for Humans.
Home-page: https://requests.readthedocs.io
Author: Kenneth Reitz
Author-email: me@kennethreitz.org
License: Apache 2.0
Location: c:userspc120pycharmprojectspythonproject1venvlibsite-packages
Requires: certifi, chardet, idna, urllib3
Required-by: etelemetry, gTTS, pandas-datareader, pandas-profiling, pyler, pywhatkit, pyxnat, streamlit, tushare, wikipedia, yfinance
Files:
  requests-2.24.0.dist-infoDESCRIPTION.rst
  requests-2.24.0.dist-infoINSTALLER
  .......

查看需要被升级的包

我们需要查看一下现有的这些包中,哪些是需要是被升级的,可以用下面这行命令行来查看,

pip list -o

output

Package    Version Latest Type
---------- ------- ------ -----
docutils   0.15.2  0.18.1 wheel
PyYAML     5.4.1   6.0    wheel
rsa        4.7.2   4.8    wheel
setuptools 56.0.0  62.1.0 wheel

查看兼容问题

在下载安装一些标准库的时候,需要考虑到兼容问题,一些标准库的安装可能需要依赖其他的标准库,会存在版本相冲突等问题,我们先用下面这条命令行来检查一下是否会有冲突的问题存在

pip check package_name

当然要是我们不指定是哪个标准库的话,会检查现在已经安装的所有包中的是否存在版本冲突等问题

pip check

output

yfinance 0.1.70 has requirement requests>=2.26, but you have requests 2.24.0.
selenium 4.1.0 has requirement urllib3[secure]~=1.26, but you have urllib3 1.25.11.

指定国内源来安装

我们要是感觉到安装的速度有点慢,可以指定国内的源来安装某个包,例如

pip install -i https://pypi.douban.com/simple/ package_name

国内源有

清华:https://pypi.tuna.tsinghua.edu.cn/simple
阿里云:http://mirrors.aliyun.com/pypi/simple/
中国科技大学 https://pypi.mirrors.ustc.edu.cn/simple/
华中理工大学:http://pypi.hustunique.com/
山东理工大学:http://pypi.sdutlinux.org/ 
豆瓣:http://pypi.douban.com/simple/

下载包但是不安装

要是我们想要下载某个包到指定的路径下,命令行如下

pip download package_name -d "某个路径"

例如

pip download requests -d "."

就是在当前的目录下下载requests模块以及其他所要依赖的模块

批量安装软件包

我们一般在看到别人的项目时,都会包含一个requirements.txt文件,里面包含了一些Python项目当中需要用到的第三方库

详解Python当中的pip常用命令

要生成这种txt文件,需要这么来做

pip freeze > requirements.txt

而如果我们需要来批量安装第三方库,在命令行中输入以下这个命令

pip install -r requirements.txt

或是移步:https://www.cnblogs.com/hkwJsxl/p/16514238.html

程序员灯塔
转载请注明原文链接:详解Python当中的pip常用命令
喜欢 (0)