• 欢迎光临~

记CM启动yarn报错:Error found before invoking supervisord: dictionary update sequence element #89 has length 1; 2 is required

开发技术 开发技术 2022-12-23 次浏览

CDH版本5.14.2

编辑:/home/cloudera-manager/cm-5.14.2/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.14.2-py2.7.egg/cmf/util/__init__.py

修改前
pipe = subprocess.Popen(['/bin/bash', '-c', ". %s; %s; env" % (path, command)],
增加“| grep -v { | grep -v }”

  pipe = subprocess.Popen(['/bin/bash', '-c', ". %s; %s; env | grep -v { | grep -v }" % (path, command)],

 重启agent

喜欢 (0)